
7 Document Preparation: LATEX and Lyx

7.1 Simplest Possible Introduction to LATEX for people who

will eventually use LYX.

Here’s the smallest LATEX document I can provide. Call it fred.tex.

\documentclass { a r t i c l e }
%%This i s the preamble , where many opt ions

%%can be s p e c i f i e d f o r more compl icated

%%documents

\makeat l e t t e r

\makeatother

\begin {document}

\ author {Paul Johnson}

\date {January 16 , 2008}

\ t i t l e {Very Short Document in \LaTeX{}}

\maket i t l e

Here ✬ s the sma l l e s t \LaTeX{} document I can p rov id e .

Type any crap you want h e r e .

Use blank l i n e s to s epara te paragraphs .

\end{document}

I want to demonstrate the step-by-step process that is used to translate “fred.tex” into a
beautiful document.

You can follow allong if you download the file “fred.tex” from my course page http://pj.

freefaculty.org/stat/ps706 and save it in your working directory.

Open a terminal and navigate to the directory where you put fred.tex.
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Open fred.tex in an editor, I recommend Emacs. (On Linux, it should be as easy as typing
“emacs fred.tex”; on Windows, the Emacs executable is called “runemacs” and if it is in your
path, then you type “runemacs frex.tex.”) Go into the middle of the document, type in some
crap. Any crap you want. Then Save and Close.

You are back in the terminal. You put to use the “backend” tools of the LATEX system to
process the source file “fred.tex.” Hopefully, your LATEX system provides you with the key
programs like “latex” and “pdflatex”.

❼ Use the latex program to process your prepared tex document, fred.tex:

latex fred.tex

❼ List the files in the directory to be sure a new file “fred.dvi” was created. DVI is short
for “device independent”file. DVI was a precursor to the more familiar PDF (“portable
document format”).

❼ To view the resulting DVI file, file.dvi, use a dvi viewing program, such as xdvi or kdvi
(or, in Windows, the preferred DVI viewer seems to be yapp):

xdvi fred.dvi

❼ You can send a dvi to a coauthor, but other readers generally want a pdf or a postscript
file.

To produce a PostScript file from the DVI file:

dvips fred.dvi

❼ To view the resulting PS file, use a postscript viewer, such as evince, gsview32, gv
(short for ghost view). On Linux, I type

evince file.ps

❼ To print the PS file, use the lpr program to send it to a printer.

lpr fred.ps

That will go to the “default” printer in your system.

❼ Here, I tell it to go to the printer called “lab” with the -P option:

lpr -P lab fred.ps

❼ The ps file can be converted to fred.pdf with a command like this:
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ps2pdf fred.ps

That conversion may not be perfect if there are some fancy features in your ps file that the
converter can’t handle. fred.tex should come through just fine, but if I had inserted a “psfig”
drawing or other postscript tricks, there could be trouble.

There are other ways to create PDF files.

❼ There’s a program“pdflatex”that will do all the work in one step. From this command,

pdflatex fred.tex

one will receive a file called “fred.pdf”.

Honestly, sometimes pdf output is not great looking. Sometimes there are details that are
needed and I don’t remember all of them. A script called “tex2pdf” seems to do a better
job with lyx files. I can share it to you if you want. Or you can get your own here:
http://tex2pdf.berlios.de/.

In case you want to write LATEX documents that have non-roman characters (for example,
Chinese or Japanese), there is another document processor you might try. The XeTEX pack-
age provides a replacement of pdflatex called “xelatex”. I’ve written a HOWTO document
for XeTEX and you should be able to find it either on the LYX website or in the folder
http://pj.freefaculty.org/latex.

7.2 Knowing Just the Smallest Bit about LATEX and a Lot

about LYX

LATEX is a format for preparing documents and a program that turns documents into beau-
tiful output. LYX is a Graphical User Interface (GUI) to the LATEX document preparation
system. It is like a word processor, but is great for writing equations and preparing academic
documents. The LYX program is something like a word processor, in that there are pull down
menus that can be used to achieve most purposes. LYX saves documents in its own format.
By default, files are saved with the suffix .lyx. LYX also has an Export option to create an
actual LATEX document, one that will be suffixed with .tex.

LaTex is a ’structured document’ environment. Everything you type has a style environment
associated with it, and so a publisher knows exactly how to turn your document into a
pleasant looking thing.

The core LATEX philosophy is that authors should not waste time on formatting. Authors
should work on words, sentences, equations, paragraphs, and the like. No author should
ever fuss over the question of whether a section title should be indented or not. Authors
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should not fiddle with paragraph indentation, or anything else, because publishers choose
those options. Authors should write documents in a more or less “generic” way so that they
can be turned into an article or book in the style of any publisher. Authors are not supposed
to fuss about trying to indent quotations “just so.” LATEX ignores most extra blank spaces
in documents. It ignores tabs. The publisher styles are the “sty” and “cls” files that make up
the collected LATEX hierarchy of “packages” that is stored in /usr/share/texmf/tex/latex.

There are various ways to work in LATEX documents. One alternative is to actually stay on
the “ground floor” and write in an environment where you actually see the LATEX markup.
The editor Emacs has an optional mode called AucTEX that provides some convenience
features for people writing in LATEX. There are also editors like “TEXmaker” or “kile” that
are specilized for working with LATEX documents. In those editors, the LATEX code is edited
without aid of any simplifying representation. For example, whenever you want the symbol
LATEX to appear, you write

\LaTeX{}

That is a “macro” that tells the processor to produce that particular symbol.

If you write in LATEX, on the ground floor, your documents are full of “mark up” like this:

\begin{equation}

e = mc^2

\end{equation}

That markup produces beautiful output like this:

e = mc2 (7.1)

In-line mathematical symbols are surrounded in dollar signs, $\alpha \times \beta$ would
print out as α × β. Subscripts are triggered by underscores and superscripts by the carot, as
in $\beta {ij}$ or $\Gammaˆ{whatever}$ generates βij or Γwhatever.

A mathematics professor that I know uses LATEX in that “ground floor” way. He edits the
files in Emacs and uses some Emacs addons to assist in the processing and viewing of the
document. I have done that, but it is hard work.

To the “hard core traditionalist,” the argument I am about to make is wrong. I don’t want
to hide from that fact. I wear their scorn with a badge of honor (apologies to Dan Quayle).
I believe that most people that I teach can make more headway running the program LYX,
which is now available for Unix/Linux, Macintosh, and MS Windows. Here’s my argument
for taking the easy road.

LATEX is great, but difficult to manage if you are not really, really devoted to it. You also
need to be in an academic environment where many people use it. A document preamble
can have pages and pages of options, most of which are difficult to master.
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Figure 7.1: Screenshot of the LYX Program

LYX is a program that looks like a word processor, but it can output LATEX documents, so it
can create the same beautiful output. Lyx has menus and point-and-click features. Consider
the screenshot in Figure 7.1.

In LYX, when I want LATEX to appear in my LYX document, I simply type LaTeX and LYX
does the rest of the work.

The main selling point for LYX is that it makes it easier, possibly even simple, to create
complicated, professional looking mathematical expressions. I believe the only way to learn
about that is to actually try it, so I’ve designed some elaborate exercises that appear in the
end of this chapter.

LYX is provided with a voluminous amount of documentation. When you run LYX for the
first time, LYX provides you with a list of things worth knowing. Under the Help menu
item, one should find a Tutorial, a User Guide, and Extended User Guide, a Customization
manual, and other things as well. I am one of the people who tries to understand instructions
when I build bicycles or repair furnaces, so I have to admit I did spend several hours pointing
and clicking in the LYX online guides. I realize that many people do not read instructions,
and instead they prefer to try, and when they fail, to either write to the lyx-help email list or
ask a professor what to do. For people who don’t read manuals, the usual answer is “RTFM”,
which stands for “Read the Fine Manual.” The word Fine may be replaced by other words
that start with F, of course.

7.3 The LYX Document Framework.

When I open a LYX document, I try to use a “template” that has the settings I want. To
create the template, I experiment until I have everthing set up in the way want, then I delete
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the content of the document except for, say, my name, and then I save it. When I create
documents in the future, I specify that saved version as the template.

Sometimes I forget to start with a template. Too bad. Then I have to re-do the settings to
fit my taste. I’ve made that mistake on purpose and kept careful notes on what is necessary
to convert the standard LYX document into a workable document.

Most of the work is done in the Document menu, under the Settings item. After you explore
that a bit, you may think it is overwhelming in its detail. I don’t have a comprehensive
knowledge of all options, even after using LYX for a decade. However, there are just a few
really vital things to check.

1. The Document Type is the first big choice. This book that you are reading was set
with the KOMA script style for books, but most of the time I use the “article” format
without any special settings for the postscript driver.

2. Change margins. Document → Settings → Page Margins. Set all margins to 1 inch.

3. Change Fonts. For me, the Latin Modern fonts make the best PDF output. Document
→Settings→Fonts. For Roman, Sans Serif, and Typewriter, I choose the Latin Modern.
I generally change the font base size to 12.

4. Make sure your paper is the correct size. Document → Settings → Page Layout. I set
the item “Format” at “US Letter” (because I’m in America, obviously).

5. In the Document → Settings → Language, I usually change the input encoding to utf8
if I’m writing a document that will be produced in English.

There is some danger here. If I cut-and-paste from other programs into lyx, and they
use some other encoding, then there may be problems later. Sometimes characters will
look like noise on the screen, sometimes the latex processor will complain.

6. I prefer ragged-right edges in output, not right-justified output as in books. That is
achieved by putting this into the Document preamble. In Documents→Settings→LATEX
Preamble, put in this:

\usepackage{ragged2e}

\RaggedRight

\setlength{\parindent}{1 em}

7. This next thing is optional for new users, but I include it because it demonstrates the
customizability of LaTex and LYX. LATEX does not automatically center graphics inside
figures. You can manually center each graphic. Instead of manually centering each I
have a preamble element that is supposed to do that for me. It goes like this.
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%I forget where I got this, but it works, usually :)

\usepackage{ifthen}

\makeatletter

\renewenvironment{figure}[1][]{%

\ifthenelse{\equal{#1}{}}{%

\@float{figure}

}{%

\@float{figure}[#1]%

}%

\centering

}{%

\end@float

}

\renewenvironment{table}[1][]{%

\ifthenelse{\equal{#1}{}}{%

\@float{table}

}{%

\@float{table}[#1]%

}%

\centering

}{%

\end@float

}

If you do not use this preamble item, then it is necessary to manually center every
graphic inside every float in your document. That is not a horrible problem, it is as
simple as putting the cursor on the left edge of the graphic, hittting the Edit menu,
choosing Paragraph Settings and then choose center. That can get tedious if you have
a lot of figures.

7.4 Exercises

Exercise 1 offers the “bare minimum” LYX user introduction. Exercise 2 shows a little R
program that creates some images, that you can then insert in your document. Exercise 3
is the big whopper, complete come-full-circle, super-great thingie that shows how the giant
LATEX experience should integrate references.

1. Create a bare bones document that uses a little math. I have a document that can serve
as a“template”for your effort: http://pj.freefaculty.org/stat/LyX-template-01.
lyx. I created that with an older version of LYX, but I believe it will work with newer
version as well. Download that, and then re-name it and open it up. I always run LYX
in a terminal, because error messages sometimes flash there. Some lazy people start
LYX from an icon launcher. Those people get what they deserve (trouble).
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a) Put your name at the top. Then with the cursor in your name (anwhere in your
name), click on the Environment chooser on the left side (where it probably says
“standard”) and change it to “author”. Then hit return to start a new line, type
in a title, and then change that paragrph style to title.

b) Type something and then mark it with the title environment.

c) Then write whatever you want.

d) Test an in-line mathematical expresion.

C means the control key. Type C-m (Control and m at the same time)
That creates a “math entry box.” Inside that blue math entry box, type this,
including the back slash, and put spaces at the end of the words:

\beta (hit space bar) \alpha (hit space bar) \gamma (hit space bar)

That should cause these symbols to “pop up” on the screen:
βαγ

Notice that when you hit the space bar, the Greek letter appears. The space bar
has the effect of telling the program to translate \beta into β.

The “math entry box” will close as soon as you hit the space bar a second time
(since you don’t have any \ symbols that are still “open”)

There is a graphical interface for choosing mathematical symbols, but it has
changed in appearance over the years and I’m hesitant to tell you where exactly it
might be. In earlier versions, there is a “toggle math panel” item under the Insert-
>Math option. In LYX version 1.6, the approach is to choose View->Toolbars,
and choose the ones you want. I do the math(auto). After that, when you hit
C-m, then a pointy-clicky math menu will appear around the edge of your screen.

If you have a really old version of LYX, you can bring up a panel of mathematical
symbols called the “math panel”. It floats separate from the document. That was
my favorite, but it is apparently gone from the new versions.

e) Start an indented display equation with Shift-Control-m. That’s the same kind
of math entry box as before, except this one is indented and centered. Tiy can
click to put in symbols.
When you are done choosing symbols from the math panel, you must click in your
document again to tell LYX you want to type more.

f) Try out cross-referencing. One of the REALLY BIG features about LYX is
that items can be labeled and then when you put in cross-references, the LATEX
processing system will make all of the numbers match up. For example, if you
insert Figures, Lyx numbers them for you, and if you insert a label inside the
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figure’s title, then that label can be used as a cross reference. Similarly, labels
can be inserted inside equations or other things.

First: let’s label a mathematical equation. Choose the display equation (a cen-
tered math thing you get from C-M). Position the cursor at the end of the math
insert box, hit the Insert menu and choose “label”. The prompt will give the
default “eq:” and you can put any word you like after that. On the screen, there
will be a marker like #eqn, but just wait–the equation will be properly numbered
in the output.

Second: insert a reference to that equation. Suppose you are typing a sentence
like “In equation XXX, we find blah blah”. You want the XXX to be replaced by
the correct number. Go the the XXX in the text, hit the Insert button, choose
Cross-Reference, and you should see a menu with all of the labels you have created
so far. Choose the right one, and then view the DVI output of your document.

You can put in labels anywhere, inside equations, figure and table titles, as well
as in chapter, section, or other headings or enumerated lists. For example, in item
1c above, I inserted a label, and I just used the cross-reference feature to refer to
that item.

As a result, NEVER manually number equations, figures, tables, or whatever. Let
LYX/LATEX do the numbering, and you will be happier!

g) Review your document. Hit the View menu, and choose DVI. That will show you
the“device independent interface” result. Usually, that is almost exactly the same
as what the postscript output would be. Next, choose View-> PDF(pdflatex).
That will display a PDF file on the screen (assuming you have a pdf viewer).

If you don’t get a pleasant looking document on the screen, then you made some
kind of mistake. We can usually fix those, I don’t want to bother too much about
it in this document. You get a mistake if you get really busy pointing and clicking
and you create some mess that LATEX can’t understand. You can also get errors if
you inadvertently insert an international character that LATEX can’t understand.

The LYX team members advise that, if you want to print a document, you should
do so from within the viewer, not from the File-> Print menu item in LYX. If you
print from the viewer, you are most likely to get what you really expect from the
printer.

h) Use LYX to export your document in PDF format. File→Export→PDF(pdflatex).

i) If you have a web page and know how to post files, then put your pdf file up there
and email me a link to let me know where the file is. If you don’t know how to
post files on a web page, you should learn, but that’s not my problem right now.
Just email it to me. In either case, please put a clear subject heading on your
email (Name-lyx-exercise.pdf or such) so I don’t mistake it for spam.
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j) Do this next step only for your own information. In LYX, export the TEX docu-
ment. File→Export→LATEX(pdflatex). This is the file that publishers want (along
with all your graphics and insert files, of course). Use an editor like Emacs to
inspect the output file, which will have the same file name as your LYX document,
but the suffix will be .tex. Then try to use “latex” and “pdflatex” to process that
tex file.

2. The second LYX exercise is mainly focused on exploring the process of creating “float-
ing graphics.” I’ve uploaded an example directory on my website in a file called
“LyxExercise-2.tar.gz”. Download that file and untar it (Linux: “tar xzvf LyxExercise-
2.tar.gz”). It will create its own directory.

One important lesson is that you need to keep track of the many different files the
belong to a project. A good habit is to work in a separate directory for every project
that you do.

a) Run the R file called “MakeSillyPlots.R” that is in the tar.gz file. A copy of
that program can be reviewed in the Algorithm 7.1. If it works, that program
should dump out 2 postscript files (*.eps), 1 pdf file, 2 png files, and 1 xfig. If the
computer you are using refuses to create a pdf or a fig file, you should just give
up and fight with that configuration problem another day. My computer really
does make all those output types.

a) Create a LYX document that includes the results of your R work. You might as
well start with a clean document. I included a file called “templateEmpty.lyx” in
the tar.gz package. You don’t have to use it, but I think it might help.

Type in any old stuff you want. Then insert a figure float for each eps or png
output file that you created with that R program. I am confident those formats
will work on all types of operating systems.

We treat the eps, pdf, and png files as “graphics” in LATEX. Proceed as follows for
each one.

b) Here’s how graphics are inserted in LATEX documents with LYX. Position the
cursor on a new line in the document.

i. Choose Insert, then Float, then Figure.

ii. Type the title of your figure–this is the title to be displayed to readers.

iii. After you type the title, while you are still inside the little title box, hit the
Insert menu, choose Label. The system will guess a label for your, something
like “fig: your title here”. Usually, I accept those.

Hit return when finished typing your title and inserting the label. The label
does not show for the reader, but you can use it for cross referencing inside
your document.
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Algorithm 7.1 MakeSillyPlots.R

x<- rnorm(333)

y<- rnorm(333)

## run this only if you are in an interactive session, so

## you can see this on the screen.

## plot ( x,y, xlab="Input Variable", ylab="Output Variable")

postscript(file="testplot-1.eps", horizontal=F, height=6, width=6, family="Times", onefile=F, paper="special")

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()

postscript(file="testplot-2.eps", horizontal=F, height=4,

width=4, family="Times", onefile=F, paper="special")

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()

pdf(file="testplot-1.pdf", height=6, width=6, family="Times",onefile=F, paper="special")

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()

png(file="testplot-1.png", height=350, width=550, type="Xlib")

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()

png(file="testplot-2.png", height=350, width=550, type="cairo")

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()

### Now dump out an xfig file

xfig(file="testplot.fig", height=6,width=6, family="Times", horizontal=F, onefile=F)

plot ( x,y, xlab="Input Variable", ylab="Output Variable")

dev.off()
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So far, you have only created an empty “floating box” for something. Finally,
put stuff in there!

iv. The cursor should be on a line by itself inside your float. If not, hit return to
get a new line. Choose Insert, then Graphics, and in that menu, navigate to
the EPS or PNG or PDF file you want to display. Note you can re-scale the
image if you want to by using the “insert graphic” panel options.

v. By default, your graphic will not be centered within the float. You treat the
image as a paragraph and center it by using the Edit→paragraph menu. If
you use my LYX document template, this is not strictly necessary because I
have a preamble component that is supposed to center graphics inside floats
when you view your document.

I want you to try to repeat this process for all of the graphics that are produced
by MakeSillyPlots.R.

Please note, LYX does not “copy and incorporate the graphic” into the lyx file
itself. LYX is not like the Borg in Star Trek: The Next Generation. Rather,
LYX (and LATEX) just make use of the file that is sitting there. If you delete
the graphic file, then LYX won’t have that figure anymore and your document
won’t work. If you want to share your LYX document to somebody, you also
have to send them copies of the graphics. Get it?

Try to experiment a bit with repositioning your image files. You might hack in
MakeSillyPlots. R to see what happens. I recall something bad but interesting
happens if you create a pdf output image without the paper=”special”option.

c) This is a special feature of LYX, but it may not work on MS Windows unless you
have the editor Xfig installed. Try and see what happens. Create a figure float.
Then, instead of inserting a graphic, choose to insert external material.

Recent versions of LYX have added an option under Insert → File → External
material. The external material is supposed to be a specialized kind of file that
LYX understands. On my system, I see a External type for things like “Chess
diagrams” and “RasterImages.” I also see an option for Xfig drawings. The R
program I provided creates a file “testplot.fig”. It is formatted for the drawing
editor XFig, a popular and long-standing Unix program. I’m a bit curious to
know what LYX on MS Windows will do with an XFig file (maybe it will bomb).
After inserting the XFig file as an External Document, LYX should be able to
display it, as if it were a graphic file. But there also will be an “Edit” option. If
XFig is installed, then something magical should happen.

XFig is mainly useful for “line art,” diagrams that appear in publications. In the
LyxExercise-2.tar.gz package, I included a fig drawing that I made for a Math
book. The figure is called “SmithSchwartz5.fig.” You can use xfig to edit that and
experiment with it in LYX.
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d) View the pdf file that is generated. I’d like to see it. If you have a web page and
know how to post files, then put your pdf file up there and email me a link to let
me know where the file is. If you don’t know how to post files on a web page, you
should learn, but that’s not my problem right now. Just email it to me with a
clear subject heading like “Lastname-lyx-exercise-2.pdf”.

3. The next step is the last big, new thing. Learn how to make an automatic list of
references in your document that includes only the things you actually cite. This is
the point where the power of LATEX becomes visible. LATEX works together with a
program BibTEX that will keep track of citation and build a list of references when
this document is finished.

Where do you get the bibliography file? I included a file called “SocialChoice.bib” in
the LyxExercise-2.tar.gz.

Inside LYX, it is necessary to set the type of bibliography that is to be used and let LYX
know where to insert the references. I almost always want social science style citations,
the type that have in-text references like Lastname (1994) or (Lastname 1994, p. 34).

Proceed as follows.

a) In Document → Settings → Bibliography, choose “Natbib”.

b) Move the cursor to the end of the document, click Insert → List/TOC → BibTEX
Bibliography. Do 2 things.

i. First, tell it where your reference files are. Click “browse”, choose the bib file
you want, click ok, then choose it again from the list.

ii. Second, tell LYX what format you want to use for references. I use a format
file I created called “apsa2.bst.” It is installed in the LATEX hierarchy on my
machines, but I think it will also work fine if you keep that bst file in the
same directory as your document and your bibliography. So choose browse
and choose that.

c) Test out your bibliography setup by moving into the text of the paper inserting a
sample reference. Click Insert->Citation and you should see a list of books and
articles appear. Choose one, and hopefully it shows up in your output. Since you
chose Natbib format, you should have incredible control over how you want each
particular citation to appear in your document. You can make things appear like
Black (1958) or Black (1958) or (Black 1958) or Black (1958, p. 44).

Warning: I had some troublewhen I inserted some citations that had had the
wrong “character encoding”. I had cut and pasted some citations from a web
browser into my bibliography file and I was “contaminated”by some strange char-
acter encodings. If you try to view your document and it fails because of “un-
known characters,” don’t panic. In my case, I just used Emacs to open the file
SocialChoice.bib and make some fixes.
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d) After inserting a few citations, in LYX try View→pdflatex and check to see if the
list of references if properly built.

e) Once you see this actually work, you should be persuaded to drop the old, silly
habit of writing a long paper and then typing in the references when you are done.
Instead, you should build a bib file as you go along and then let LATEX make the
references for you.

I’m giving you the bibliography file, just use it. Do you wonder where that came
from? A bibliography can be directly edited with an editor like Emacs (or TINN,
or GVIM, or any other editor that does not try to “format” things for you, such
as MS Word). The bib file is just a carefully formatted “flat text” file. If you
inspect my bib file, you should be able to discern a certain rhyme and reason to
creating complete citations. LATEX allows names either in the format “James Q.
Wilson and Roger P. Pettibone” or “Wilson, James Q; Pettibone, Roger P.”) I
tried to use Emacs to create bibliography entries (there is a helper component in
Emacs for that), but I found the formatting too tedious. I only use Emacs for
“bug shooting” bib files.

f) There is a pointy-clicky free program called pybliographic that is handy for this
kind of thing. It works great in Linux. On Windows as well as Linux, I’ve also
used a Java program called “JabRef” that is handy. Java programs run (more-
or-less) on all operating systems that have Java, including Linux, Windows, and
Macintosh. I’m told that people can also spend money on programs like Endnote
that do this sort of work. EndNote can export a bibtex file that can be used with
LATEX.

In case you can’t make the LYX file work with the bibliography, that’s too bad. I have
a working example file “pjCanCiteStuff.lyx” and if you put that in a folder with the
bibliography and biblio-style file, you can test it on your system. If you open that file
and view it in pdf, it should give you some encouragement.

7.5 LATEX and LYX Paragraph Environments (Section)

In the title for this section, I have a marker (Section), which I’m using to represent the idea
that the words “LATEX and LYX Paragraph Environments” are marked as a LATEX Section
in the document that I’m preparing. That tells LATEX that the header is supposed to be
numbered and set in a bold faced print with extra white space around it.

I started to wonder about all these different “environments.” In LYX, there is a “menu”
chooser that specifies the paragraph environment. I’m referring to that thing on the left side
of the LYX graphical interface, where it currently shows “Enumerate” in this snapshot:
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This chooser is used to specify the type of paragraph, e.g., a chapter title, numbered section,
one item in a list, your name, and so forth. In the old MS Word days, we would call them
“paragraph styles”.

Why so many environments for paragraphs? What are they? What are they for?

In some special cases, like “Title”, “Author” and “Abstract”, the paragraph environment can
have a dramatic effect of moving “text” into a desired position in the final document. If you
put in your name, and mark that line as an “Author” environment, then your name will be
moved to the front of the document when it is printed. The particular font and position is
specified by the LATEX document class.

In most other cases, the paragraph environment does not “move text around” so much as
shape it in a desired way. By default, all ordinary text should be of the “Standard” type.
Standard type will follow whatever conventions are established within the document. Most
of the other paragraph types are for “section numbers” or “special formats”.

I’m trying to make this a self documenting example, but it is tedious. I will use the
typewriter font to insert markers for my paragraph environments, except when I’m us-
ing the “Standard” environment.

7.5.1 List types (Subsection)

Any Section, Subsection, or Subsubsection item is automatically numbered. A starred
section item, as in Section * , is not numbered, but it is “set off” from the other text.
That’s what the star means–no number.

Enumerated List (Subsubsection *)

I now choose the paragraph style “Enumerated” (actually, I use the keyboard shortcut Alt-p
e) and look what happens:

1. Enumerated list is automatically numbered. (Enumerate).

Hit enter and LYX offers a second enumerated item
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2. This is a second enumerated item. (Enumerate)

a) If you hit return, and then do Alt-Shift-right arrow, then an “a” will pop up to
start an indented enumerated item. (Enumerate)

You can put this standard paragraph within the enumerated item if you want.
It will ”inherit” the indenting. After hitting return, change the paragraph type
to “standard” and then hit the button to “increase list depth” so the paragraph
“goes under” the enumerated item. If you can’t find the button, then click “Edit”
and choose “Increase List Depth”. I use a shortcut key (shift-Alt-right arrow).
(Standard).

b) Enumeration in that sub-level continues until you make it stop (Enumerate).

If you want to go to a higher enumeration level, you can hit enter, and then either
do “Edit” and “Decreate List Depth” or use a shortcut key shift-Alt-left-arrow.

To stop adding items, hit return and change the environment type to “standard”,
for example (Alt-p s).

c) Just to be perfectly clear, when you are in an Enumerate item, and hit return,
you get a new number in the sequence.(Enumerate)

i. To go to a sub point, hit return then shift-alt-right-arrow, which is the same
as Edit-> increase item depth.(Enumerate)

A. Hit enter again, do shift-alt-right-arrow again, to get another subpoint(Enumerate)

ii. Hit enter again and you are stuck adding more items. (Enumerate)

A. To go to a higher level in the outline, do shift-Alt-left arrow (or decrease
item depth).(Enumerate)

B. To quit adding enumerated items, hit return and change the paragraph
type.(Enumerate)

Itemized List (Subsubsection *)

❼ Itemized Items have bullets (Itemize).

– To start a list, I use shortcut Alt-p i. But you can menu pulldown “Item-
ize”(Itemize).

✯ One can put paragraphs within items. Hit return at the end of the item, then
do Edit-> increase item depth or with a shortcut shift-Alt-right-arrow. Then
change the paragraph type to Standard. In LYX, a red bracket should appear
on the left to indicate you are inside another environment.(Itemize).
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A Description List (Subsubsection *)

Thing the word on the left is described here. (Description)

Item a single word or Control-shift separated words can be on the left side of the descrip-
tion.(Description).

Here’s a key term a description has a big bold faced phrase on the left and then a longer
description on the right. Note ordinary spaces will separate your terms on the left side.
Use Control-Space to hold them together. (Description)

Like all “list” environments, a description environment will keep making more description
items when you hit enter. (Description)

I don’t use many of these description lists because I don’t need them too much. (Description)

7.5.2 Special Types of Paragraphs (Subsection)

Quote Me (Subsubsection *)

Two environments start with our favorite letter, Q!(Standard)

Quote (Subsubsection *)

Here is a short quote. One wonders how a “quote” is different from a “quotation”
in LATEX? Many people have wondered the same thing. The answer: Indentation
(Quote).

When you hit return in a “quote”, it continues in the quote, with no in-
dentation. Sometimes people want to have no indentation, even though
it seems like they ought to.(Quote)

See, the quote continues with no indentation.(Quote)

Quotation (Subsubsection *)

Here is a short quotation. One wonders how a “quote” is different from a
“quotation” in LATEX? Many people have wondered the same thing. The answer:
Indentation (Quotation).

When you hit return in a quotation, it is indented (Quotation)
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Verse (Subsubsubsection *)

On the other hand, the Verse environment might be used by a poet or a social
scientist who had a peculiar style for the presentation(Verse)

of ideas.(Verse)

Lyx-Code (Subsubsection *)

In case you want a more or less verbatim presentation of what you type, with a type writer font, the L

It is often used for computer code examples, as in R-Code.(Lyx-Code)

The Document class will usually cause this to be set in a type writer font. I suspect it is related to the

I’m getting some very peculiar line breaks in this example, and it makes me suspect I broke some settings in my system. That is a downer.(Lyx-Code)

Paragraph (Subsubsection *)

More than one person has come to me in a tizzy because the“Paragraph”environment
is not what they expect. (Paragraph)

I have to admit that I don’t really know why a person wants the “Paragraph” en-
vironment.” I’ve seen more than one student ruin a paper by using the paragraph
environment. I never have used one. (Paragraph) In the LYX documentation, I think
it says the paragraph environment is for some special purposes, and I don’t know what they
might be. I do notice a very strange thing. In my output, this “Standard” environment gets
merged onto the “Paragraph” output in the line before.(Standard)

7.5.3 I am finished (Subsection).

In the article style (KOMA script), LYX offers the environments I’ve demonstrated, plus a
few more for abstracts and such. But if you understand the role of “Standard”, “Section”,
“Section *”, and “Enumerat”ed lists, I expect you will understand the main piece.

7.6 Keybard Shortcuts I Remember Off the Top of my

Head

In the very bottom of the LYX graphical user interface, there is a small notification bar that
tells you what’s going on. As I’m typing, it says “Font: Default.” But if I choose a menu
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