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The Center for Research Methods and Data Analysis at the University of
Kansas endorses LATEX as a document preparation framework and we also encourage new LATEX users to consider LYX as a graphical interface for document
preparation.
This is a guide for learning about LATEX from LYX. As many people have noticed, LATEX offers a seemingly endless array of special packages, functions, and
code arrangements that emerge from a countless number of researchers in virtually every country in the world. Many new LATEX users simply take a professor’s
template document and revise “inside the borders” while they learn their way
around. LYX can help because it offers a Graphical User Interface that helps
novices get complicated-looking results without too much suffering.
1. Open LYX, choose File -> New in the pulldown menus. That creates the default
document, which on most systems is an article. Type something.
a) Strictly for the record, the pull-down menus in my LYX-2.1.4 look like this:
b) Below the pull-down menus, there is a button bar (“ribbon”?) that looks like this:

2. In the LYX 2.1.4 menu bar, do you see two icons like this:
? The one on the left
A
can send your document to the L TEX Compiler, choose View PDF (pdflatex) to see
if your computer works correctly to compile and view a PDF version of the document.
The one on the right is the update button. If you already compiled a previous version,
this might be faster than compiling again from scratch and it will use the same PDF
display. (I don’t generally use it very much.)
3. File -> Save As. Save your LYX file in a separate folder. Creates a file with suffix
*.lyx
4. File -> Export -> LATEX (pdflatex). Creates a file with suffix *.tex.
5. Check your file folder for the output
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a) IF YOUR OPERATING SYSTEM’s FILE BROWSER HIDES SUFFIXES, TURN OFF THAT FEATURE IMMEDIATELY. It is absolutely
certain you will become frustrated and upset when all of the files in a single folder
seem to have the exact same name (because .tex, .lyx, .pdf, or other suffixes are
hidden).
b) Open the tex file and review its contents. If your computer has to an editor
with special features for editing a LATEX document, such as TexStudio, Tex Shop,
TexMaker, TextMate, or Emacs, please use that editor.
6. In Lyx, choose View -> Source Pane. On right side of source pane, use the pull down
menu to change “Current Paragraph” to “Complete Source”.
7. Write an alpha (α) and a beta (β) in the middle of a line.
a) Type “Ctl-m” (Ctl= CONTROL key. This is same as pull down menu “Insert
-> Math -> Inline”).
b) That should open this box
ribbon:

and the bottom of LYX should have a math

c) While you are learning LATEX, this will offer an invaluable tool to find symbols
and learn how to insert structures. Play around with some of those, find α, β.
d) When you are “inside” the math box, you are inside a special environment. They
assume that if you type something irrelevant, then you mean to go outside the
math box. Examples of irrelevant things that bump you out of math box: “space
bar”“down arrow”“up arrow.”
e) Monitor the Source Pane as you do this. It should become apparent that
i. β is $\beta$ in LATEX. α is $\alpha$.
ii. Do you still have your LATEX document open in TEXStudio (or whatever)?
Go in there, type $\beta$ and compile it.
iii. LYX math mode uses that standard LATEX markup for greek symbols and
math. If you know how to type something in LATEX, you can simply type
same in the LYX math box, but don’t type the dollar signs that go with. The
math box puts in the dollar signs for you.
8. Insert a centered “display math equation”. The short-cut key is “Ctl-M” (Same as menu
“Insert -> Math -> Display Formula”). That gives you a centered math box on its
own line.
a) Using the math tools at the bottom, point and click your way to some kind of
formula.
b) Monitor the Source pane, see how LYX suggests the LATEX ought to be written.
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c) LYX Source pane now allows “Copy”, and you can then paste the math markup
into your LATEX editor.
d) Some caution may be needed. To allow some fancy math, LYX may have revised
the preamble.
9. Experiment with “tabular” objects in LYX. In LATEX, a “table” is a floating, automatically numbered environment in which users can insert “tabular” things (or other
content). Ignore the floating part, just concentrate on the tabular for the moment.
a) Insert -> Table.... Choose the default, 5 rows 5 columns.
b) Type entries into the cells. Study the Source Pane as you do this. What do you
deduce?
i. New columns begin with “&” and at the end of a row there is a symbol
“\tabularnewline”.
c) The default table is about the ugliest thing you can imagine. Use the tools at
the bottom of the LYX display to get rid of all of the vertical lines. Note how the
Source View changes.
d) Right click in the Table display. You should see a lot of choices, plus access to a
much more elaborate “Settings” menu.
e) In the Settings, I want to draw your attention to one superior feature. Specify a
column width in inches or centimeters.
f) After you make the table look beautiful, you can copy it into a LATEX document.
This may not compile right away because LYX has also enriched the preamble to
allow for the fancy features you have been using.
10. If you can find an image file on the Internet (?), save it in your project folder and then
try Insert -> Graphics. These days, it is almost for sure that your LYX program
can handle images in formats like png and jpg.
11. Did you notice that your PDF output looked fuzzy? That happens because the default
LATEX setup uses fonts that were not intended for PDF output. It is up to you to
change that. LYX shows how. Choose menu Document -> Settings -> Fonts.
a) Change your Roman, Sans Serif, and Typewriter fonts. I almost always change to
“Latin Modern”, but there are plenty of good options. I generally leave “Default
family” and “LATEX font encoding” unchanged. I’ve never altered the Math font
and have not altered CJK in about 10 years.
b) The Base Size: defaults to 12, I often change that to 11.
c) Most fonts you choose are not “scalable”. An exception is Helvetica. Change the
Sans Serif font to Helvetica, if you have that option, you’ll see what I mean.
d) Warning. These changes alter the document preamble in possibly complicated
ways. If you do this, I suggest you run File -> Export -> LATEX (pdflatex) so
that you have a complete copy of the preamble that you can use in your LATEX
document.
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12. Try out a floating figure.
a) Insert -> Float -> Figure. When you type a title in the box, and then compare the Source Pane, you’ll see that LATEX refers to your title as a “Caption”.
b) Move the cursor outside of the title box area, but stay inside the float. Hit the
Return key and type a letter. LYX will allow you to type either before the figure
title or after. We are not required to insert a graph here, it is OK to put in
anything you like. Better try to compile the document, see if it still works.
c) This next step has changed in LYX, so don’t worry if it looks different for you.
Left click near the end of the figure caption. So far as I know, placement is not
vital, but I have a habit of doing it at the end of the caption. In the LYX pulldown
menu choose “Insert -> Label”. A label does not show in the document. It is
a handle you use later to refer to this figure.
d) Inside your float, try Insert -> Graphics.
e) Compile your document, see where your graph appears.
f) If you don’t like where your graph appears, right click on the “float: Figure”
handle on the floating figure object, choose “Settings...”
13. Try out a floating table.
a) Insert -> Float -> Table.
b) Type a caption in the title area.
c) Left click at the end of your caption, then pull down Insert -> Label...
14. Look back at your centered “display math” equation. You might like to number that
and have a label for it too. If you right click on the equation, newer LYX will show a
menu. Insert a label. Usually that will turn on the equation number.
15. Now bring together all of your labels in a sublime sentence.
a) I suggest you type in a new paragraph
I am the leader of the free world and in Table
b) Stop typing, pull down “Insert -> Cross Reference”, choose your table object’s label.
c) Then I suggest you keep typing
and I am the mightiest LATEX user on the Titianic because in Figure
d) Pull down “Insert -> Cross Reference”, choose your figure label.
e) Then I suggest you keep typing
And because in equation () I am the meanest shadow in the darkness.
f) Move the cursor back between the parentheses, do “Insert -> Cross Reference”, choose your equation’s label.
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16. Experiment with the Environment Chooser in the top left of the LYX Graphical Interface. Depending on what kind of content you are typing, it might say
or
or something else. An ordinary paragraph is Standard. Don’t use
the one called “paragraph”, it is for something different.
a) Choose enumerate. That should give you numbered items, like this document.
b) Notice enumerate is a nested environment. Type one thing, hit enter, the next is
numbered. The TAB key will indent and renumber. The TAB effect is the same
, for which the tooltip is “Increase Depth”.
as the menu button
c) The itemize environment is a “bullet point” list.
17. Experiment with environments Section and Section* and Subsection and Subsection*.
18. Use Listings, not Verbatim, to insert material from other programs.
a) The LATEX Verbatim class is often recommended, but not by people who do a lot
of writing about computer programs. It has weaknesses that cause me to never
use it anymore.
b) Instead, I use the Listings class, which is a very flexible framework that works
well.
c) LYX can help with Listings. In the LYX Menu, choose “Insert -> Program Listing”.
That should open a little box where you can type material. When you compile
the document, that material will be printed in a “monospaced typewriter font”.
d) Suppose you have a program open and you have some output you want to put
into your document. One way to do this is to copy the material and choose “Edit
-> Paste Special.” Don’t do regular paste. Choose Paste Special, then Plain
Text, DO NOT choose to join the lines.
Here is an example of what some R output looks like in a Listings environment:
1
2
3
4

> sessionInfo ()
R v e r s i o n 3 . 2 . 3 ( 2 0 1 5 −12−10 )
P l a t f o r m : x86 64−pc−linux−gnu ( 6 4 −bit )
Running under : Ubuntu 15 . 1 0

5
6
7
8
9
10
11
12

locale :
[ 1 ] LC CTYPE=en US.UTF−8
[ 3 ] LC TIME=en US.UTF−8
[ 5 ] LC MONETARY=en US.UTF−8
[ 7 ] LC PAPER=en US.UTF−8
[ 9 ] LC ADDRESS=C
[ 1 1 ] LC MEASUREMENT=en US.UTF−8

LC NUMERIC=C
LC COLLATE=en US.UTF−8
LC MESSAGES=en US.UTF−8
LC NAME=C
LC TELEPHONE=C
LC IDENTIFICATION=C

13
14
15

attached base packages :
[1] stats
graphics grDevices u t i l s

16
17
18

l o a d e d v i a a namespace ( and not a t t a c h e d ) :
[1] tools 3.2.3
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datasets

methods

base

e) The Listings class has two features that make it very useful. You can learn about
one of those special features in LYX, the next I’ll explain in a moment.
In Lyx, after you put some material into your Listing, right click in the Listing area
and choose “Settings”. When I do that, I almost always change the tabulator
size to 2 (save space!) and turn ON these buttons
 Break long lines
 Extended character table

Sometimes I experiment with Line numbering, as in the display above.
In my Document-wide settings, I have Latin Modern as the Typewriter font.
Sometimes I notice that if I use a symbol like “˜”, it does not show in the output
unless I set the font that way (the default font set has limited symbols).
f) The second special thing is that Listings defaults can be set in the preamble. This
document has quite a few special features in it because I wanted you to see the
potential beauty of this, but generally not too much is necessary. For example,
I’d often have only
\ l s t s e t { t a b s i z e =2, b r e a k l i n e s=t r u e }
in the preamble.
g) BE AWARE of this problem. If you paste in output from R that has “fancy
quotes” (slanted quotes around the stars on p-values, for example), you will get
errors compiling your document. So you have to either 1) use the R options
command to set useFancyQuotes=FALSE or 2) delete those fancy quotes from
the pasted in material or 3) change your LATEX document encoding. I recommend
1 or 2.
19. If you have overcome the shock of the LATEX & LYX experience, the last thing I ask you
to investigate is the fundamental structure of the LATEX document. Choose “Document
-> Settings”. This concerns settings that are generally document wide, and it will
take some time before you know which ones will ruin your document and which will
have a happy result. Here are a few more highlights.
a) Document Class. The default class is “article”. If your computer has other classes
installed in your LATEX distribution, you migth want to try some. I remember
giggling with delight at the formality of the “American Mathematical Society
Book” document.
b) Sometimes document classes fail because your computer doesn’t have a required
piece. So it is wise to make one change at a time and then try to compile the
document.
c) When I begin to use LYX on a new computer, I have a list of document changes
I make and then I save them as my default. The settings I use are described in a
separate write-up about creating an article template.

6

d) When all else fails, and LYX has no menu or chooser for your fancy settings, there
is always the “old school”“LATEX Preamble” in Document settings.
e) Come to think of it, the LYX GUI also allows you to type raw tex as well. That’s
does. Among LYX oldtimers, this is known as the ERT
what the TEX button
button. Guess what that stands for? “Evil Red TEX”.
20. For a listing of my other LATEX and LYX guides, please see “LATEX, LYX, and Sweave
Notes” http://pj.freefaculty.org/latex. That points to a number of documents,
most of which are housed under the folder http://pj.freefaculty.org/guides/
Computing-HOWTO/LatexAndLyx.
In particular, I draw your attention to:
a) LYX Beginner’s Guidehttp://pj.freefaculty.org/guides/Computing-HOWTO/
LatexAndLyx/LyX-Beginner/LyX-Beginner-1.pdf.
b) Developing a LYX Template http://pj.freefaculty.org/guides/Computing-HOWTO/
LatexAndLyx/LyX-article-template/making-template-20150827.pdf and the
resulting LYX tempate document http://pj.freefaculty.org/guides/Computing-HOWTO/
LatexAndLyx/LyX-article-template/making-template-20150827.pdf
c) I also developed a template (and LATEX class file) for dissertations at the University of Kansas. That has been approved by the Graduate School and it
is hosted in their pages, but you can always find the latest and greatest at
http://pj.freefaculty.org/guides/Computing-HOWTO/KU-thesis
21. If you ever start to think you ought to use MS Word or similar instead, review this website again: “Charlie’s Diary: Why Microsoft Word must Die” http://www.antipope.
org/charlie/blog-static/2013/10/why-microsoft-word-must-die.html.
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