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This is a survey of some key steps in document preparation with LYX. It is intended to facilitate
the user’s transition from a first-time LYX user to usage of special features that are necessary to
make truly professional-quality documents. It also offers advice about interacting with the LYX
user interface.
The Center for Research Methods and Data Analysis at the University of Kansas endorses

LATEX as a document preparation framework and we also encourage new LATEX users to consider
LYX as a graphical interface for document preparation. The CRMDA offers guides that range
from the elementary first-use of LYX to the completion of a doctoral dissertation with it.
Questions or comments can be directed to the author: <sdshort@ku.edu>.
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1 Introduction

This document is a collection of important tips and tricks for authors who are making the transition from
Microsoft Word (or similar) to the more structured document preparation framework known as LATEX.

We’d like to start by criticizing MS Word, but only briefly. We expect most people who find this document
already know what’s wrong with Word. Its terrible. Many users report severe frustration when trying to
format a document in a consistent (and seemingly simple) way. Users have questions like “Why are the
fonts not consistent throughout this document?” “Why does Word want to keep adding space between my
paragraphs?”, “Why does Word not indent correctly when I tell it to?”, “Why does Word ignore all the
defaults I try to set?”. More advanced users, often under pressure of a deadline, wrestle late into the night
trying to make Table 4 look like Table 1, and they never quite get there. “Why do my
equations/tables/figures look terrible?”

People usually turn to LATEX when they are either 1) at the end of their wits after an epic struggle with
Word, or 2) an advisor or publisher requires them to prepare documents with LATEX. LATEX has quite a few
powerful features that are not available in Word. In LATEX, one finds an elegant framework that
automatically numbers sections, equations, figures, and tables. Users are able to make cross references
between sections and the cross-references update themselves as the author adds more sections and
equations.

LATEX is a document preparation framework that emphasizes consistency and compliance with publishing
standards. The proponents say that it allows authors to concentrate on authoring, not concerning
themselves with formatting and styling elements that are controlled by publishers. There is perhaps a
non-trivial amount of truth in that, but it seems obvious to us that LATEX does require plenty of formatting
labor on the part of an author. There’s no denying the fact that writing LATEX documents is difficult and,
like Word, sometimes frustrating. The argument in favor of LATEX, however, is that, in the end, one can be
certain that the result will be internally consistent and visually appealing. And there is another element
that factors into our endorsement of LATEX. It is a free, open source initiative created by a professor
(Donald Knuth) for other academic authors. One of the reasons we decline to use Word is that it is an
expensive, commercial, proprietary framework.

LYX is graphical interface that can generate LATEX documents. It is a free, open source program that many
consider to be a complete, “drop in” replacement for MS Word. LYX does not produce the output, it relies
on the LATEX document preparation programs to produce high-quality PDF documents. In addition LYX
2.0 now has many features Word users demand, including on-the-fly spell checking, and the ability to track
changes.

First time LYX users should probably start with the LYX for beginners material that we have
prepared,:http://pj.freefaculty.org/guides/Computing-HOWTO/LatexAndLyx/LyX-Beginner (look for
the pdf files). This document provides some more detail on elements that we think are necessary for LYX
users to produce a truly professional-looking document. It begins with some basic instruction on working
with LYX, and then steps through a variety of specific tips that I have accumulated through the first six
months of working with LYX and LATEX.

This document is not a replacement for the LYX website http://www.lyx.org or the extensive documen-
tation that is provided with LYX itself. Users are urged to start LYX, hit the Help menu, and spend some
time getting acquainted.

2 Insert Floating Tables and Figures

Tables and Figures are “floating” document elements in LATEX. They are positioned automatically
according to principles of publication that are controlled in the document’s setup. Users can, quite easily,
override the default placement process.
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Creating Tables and Figures is a two step process that puzzles most LATEX users. One creates the floating
container, and then inside that container one must create the table or figure to be displayed.

2.1 Make a table

Place your cursor in your document in the vicinity of your discussion about a table. .Click “Insert” ->
“Float” -> “Table”.

An new table will automatically be numbered. Next to the number, there will be a red box where in which
a title is added.

Hit “enter” after the Table’s title box. Essentially, that “makes space” for new content. It is like starting a
new line. In LATEX, a numerical array is called a “tabular”. Insert one by clicking Insert -> Table ... in the
LYX pull-down menus. Specify the desired number of rows and columns (below see 3x3 example) and begin
entering information.

The default for the LATEX tablar in LYX is to have the first row separate from the rest. The LYX GUI
makes it easy to customize these lines. The easiest way to describe is as follows. Highlight the whole row,
right click and select “More”, and uncheck “Bottom Line”.

You can use these options to customize the table to your liking,such as adding/removing extra rows or
columns, and merging rows or columns with the “multirow” and “multicolum” button (just highlight the
cells you would like to merge). You can center the table by right clicking in the float table box, and
selecting “paragraph settings”. Here is a cleaner version of my table.

2.2 Insert a Figure Float

Place your cursor in your document in the vicinity where you would like to write about a graph. Click
“Insert” -> “Float” -> “Figure”. The figure will automatically be numbered. Type a title in the little red
box.

There is a weird difference in publication standards for figures and tables. While Tables have the title at
the top, it is more usual to have titles for Figures at the bottom. If you want your Figure title at the
bottom, click at the beginning of the word Figure and hit enter to “make some space” where you can insert
a graphic. outside of the red box for the title, but stay inside the “float: Figure” box. Hit “enter” to start a
new line. Now you can insert a graphic for your figure by clicking “Insert” -> “Graphics...” and browsing
for the file. You will likely want to adjust the size of your figure, and you can change the dimensions by
right clicking on the image and selecting “settings”. In Figure 1 I have the dimensions specified as 4 inches
wide and to maintain the aspect ratio for the height.

Table 1: This is the title of my table
Variable X Y

X 1.0 0.3
Y 0.3 1.0
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Table 2: This is the title of my cleaner table
Variable X Y

X 1.0 0.3
Y 0.3 1.0

Figure 1: This is the title of my figure, and its on the bottom

2.3 Go back and insert labels

In the title boxes for your figures and tables, it is wise to get in the habit of inserting labels. These do not
show in your document, but they can be used for cross references later. To do that, click in the title and use
the pull-down Insert -> Label.

3 Mathematics

LYX has an amazing equation editor and I have found much faster to work with than MS Word’s default
equation editor, or the popular, yet costly ($60) MathType software. Most old-time LYX users will use the
shortcut Control-M. There is a pull-down menu, however. Click “Insert” -> “Math” -> “Display formula”.
This will open a red outlined equation editor box. Below is an example displayed formula.

Σgt = ΛgtΨgtΛ′
gt + Θgt
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To write your math formula inline with your text, just select “Insert” -> “Math” -> “Inline formula”
instead. Now you can type your formula inside of your paragraph. For example, in our previous equation
Σgt= the covariance matrix for each group at each tine point.

A toolbar at the bottom of your LYX window will appear and you can select letters, operators, etc. from
there. However, I would strongly suggest you learn some of the keyboard shortcuts in Table 3 below.

3.1 Number the equation

It is easy to number equations by right clicking on the displayed formula and selecting “Number Whole
Formula” or “Number this line” depending on your preference. Alternatively, when inserting math click
“Numbered Formula”. LYX will automatically number your equations. Below is the same equation from
earlier now numbered.

Σgt = ΛgtΨgtΛ′
gt + Θgt (1)

4 Link Together Several Documents.

Make a child document

If you are writing a document with multiple chapters, such as a dissertation, you may want to keep the
chapters in separate files, but have them all follow the same format. For example in the KU
Thesis/Dissertation template (see http://www.graduate.ku.edu/formatting and a full set of links on
http://pj.freefaculty.org/latex) there is one “master” document that contains all the information for
formatting, the title/acceptance page, table of contents, and bibliography. Within this “master” document
are “included files” that tell LYX to add other LYX documents in this section. These additional documents
are called “child” documents.

To specify that the document you are working on is a child document, click “Document” -> “Settings” ->
“Document Class” and check the box “Select default master document”. Next, use the file browser to
locate the master document.

To include child documents in your master document simply click “Insert” -> “File” -> “Child Document”
and browse for the file you would like to include as a child document.

5 Using BibTEX

A full discussion of BibTEX is worthy of its own document and readers are strongly encouraged to learn
more about BibTEX and using a program such as JabRef to manage BibTEX libraries. Simply put, a
BibTEX file (.bib) is a text file that has the information for all of the references you may want to cite in a
document. You can add that BibTex file to your LYX document so that you can then reference articles and
have a bibliography/reference section automatically created at the end of your document.

First, you need to link a BibTEX file to your document by clicking “Insert”-> “List/TOC” -> “BibTEX
Bibliography”. Use the “browse” button to select your .bib file. You will want to make sure a program,
such as JabRef, has generated BibTEX keys for all your reference entries, as these keys are what you will
use to cite the entry in your document. Next, click the citation style you would like to use. The style
“apalike2” seems to produce the best APA version 6 style I have seen. You should now see a grey box in
your LYX document that states “BibTEX Generated Biblography”. When you compile your document, your
bibliography will be printed here.
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To insert an in-text citation into your document click “Insert”-> “Citation”, and a new window will open.
If you have successfully added your BibTEX library, a list of available citations will appear in the left box.
You can add the citations you want to use to the “Selected Citations” box and then customize how you
would like the formatting to appear under the “Citation style:” drop-down menu. If you are using a
BibTEX style such as apalike2, then your citations will automatically be ordered correctly in text. Any
in-text citations you insert will automatically referenced in your BibTEX generated bibliography. Assuming
you have set up everything correctly, you no longer will need to do a reference check on your documents.I
am beginning to wonder how I wrote papers without this feature.

6 Tips and Tricks

6.1 Use cross-references

This is most likely my favorite feature of LYX. Imagine you have created a document with several
numbered equations, tables, and/or figures. Perhaps a reviewer asks you to add a table at the start of your
document. If you prepared your document in MS Word, this most likely means that you must manually go
back and renumber all of your tables (e.g., the former Table 1 becomes Table 2, Table 2 becomes Table 3).
In addition, you would need to make sure in your document every time you referred to the table formerly
known as Table 1, you now change it to Table 2. This process can be incredibly tedious and error prone.

With LYX, you can use the cross-reference feature to avoid this problem. You can think of a cross-reference
as a tag or a label for your stuff that you can use in the document instead of manually typing out the
number. Suppose we want to reference our numbered equation from above.

1. First we need to create a label for our equation. Right click on the numbered equation and select
“Equation Label”

2. Give your equation a name. I recommend sticking with short names, and maintaining the suggested
prefix “eg:”

3. In your document locate where you would like to reference the equation’s number.

4. Click “Insert” -> “Cross-Reference...” and select the label for the equation you just created.

A gray box titled “Ref:eq:YOUR_LABEL_HERE” will appear in the text. When you compile your
document, this box will be replaced with just the number for the equation. For example, here’s my
reference for the above equation 1.

Cross-references can be used for many things, including tables, figures, and equations. You now can just
use these cross references in your document instead of typing out “Table 1”, “Equation 1.2”, or “Figure 3”
every time you want to reference the item. This feature is incredibly helpful!

6.2 Use keyboard shortcuts

LYX has several keyboard shortcuts that can save you time and free you up from being mouse dependent.
First, you can view the default keyboard shortcuts by clicking “Tools” -> “Preferences” -> “Editing” ->
“Shortcuts”. There’s a search bar called “Show key bindings containing” where you can type in what you
may be looking for. Many standard keyboard shortcuts like Ctrl+s for save, Ctrl+c for copy, Ctrl+v for
paste, Ctrl+z for undo, Ctrl+b for bold text and Ctrl+u for underlined text all work. However, Ctrl+i
does NOT work for italics. For that, use Ctrl+e.
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Table 3: LYX Keyboard Shortcuts
Action Shortcut

View PDF of document Ctrl+r
Update PDF of document Ctrl+Shift+r
Insert numbered section Alt+p 2

Insert numbered subsection Alt+p 3
Insert numbered subsubsection Alt+p 4
Begin an itemized bullet-list Alt+p i

Begin a numbered list Alt+p e
Return to standard paragraph format Alt+p s

Insert math formula Ctrl+Shift+m
Insert inline math formula Ctrl+m
(In math mode) subscript _ (underscore)
(In math mode) superscript ^ (Shift+6)

(In math mode) add Greek letters (e.g., Σ) \“Name of letter” (e.g., \Sigma)
(In math mode) add lowercase Greek letter (e.g., σ) \”name of letter” (e.g., \sigma)

(In math mode) exit math formula tab
Note. The “+” indicates that you press the keys together. For example, to create a new section in your
document press both Alt and P, release the keys, and then press the 2 key.

6.2.1 Default keyboard shortcuts

Here are a few default keyboard shortcuts I try to remember. Recall, the “+” symbol means you press the
keys together.

6.2.2 Create your own keyboard shortcuts

You may want a shortcut to perform a task quickly. For example, when writing my dissertation I wanted a
keyboard shortcut to insert citations so that I did not have to click “Insert” -> “Citation” every time I
wanted to cite something. There was no default keyboard shortcut, but LYX allows you to make your own.
Here is an example of how to create a shortcut for that task.

Click “Tools” -> “Preferences” -> “Editing” -> “Shortcuts”. Search for the function you would like to
make a shortcut for by typing in the “Show key-bindings containing” box. Here I have typed “citation” to
find the insert citation function.
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Click on “citation-insert” and click “Modify”.

On the “Shortcut:” line click in the empty gray box. Now press the set of keys you would like to be the
keyboard shortcut for the function. If you press a set of keys that are already assigned to a function, you
will be given an error and told to try a new set. Here I have selected Ctrl+Shift-X to be my shortcut for
inserting citations.
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Click “Ok” and “Save” to save your shortcut. I have no good reason for why I selected Ctrl+Shift-X
besides the fact that a) it seems the keyboard shortcut was not being used for another function in LYX, and
b) I could easily press the keys with one hand. Just be sure you do not overwrite some important function.

6.3 Add notes or comments in your document

Notes can be added in a document that are viewed in the LYX editor, but not in the final produced PDF.
To add notes simply click the yellow note icon on the toolbar, or click “Insert” -> “Note” -> “Lyx Note”. If
you are viewing this document in LYX, you should see my note. LYX notes are not printed or exported to
LATEX.

Notes are different from comments. Comments are exported to LATEX as LATEX comments, but they are not
printed in the PDF.

Finally, Greyedouts are text entries that are printed in the final document as grey text. This is my Greyed
out example. You can change the color of Greyedouts by clicking “Document” -> “Settings” -> “Colors”.

6.4 Turn on/off on-the-fly spell checker

I like “on-the-fly” spell checking where misspelled words are underlined with a red squiggly line. You can
turn this feature on in LYX by clicking “Tools” -> “Preferences”. In the toolbar on the left select
“Language Setting”-> “Spellchecker” and check the box “Spellcheck continuously”.

When this feature is on you will have red dots underlining words spellchecker thinks are misspelled. Right
click and select the correct suggested word, or if you are confident you have spelled the word correctly, you
can add it to the dictionary so that spellchecker no longer views the word as incorrect.

6.5 Compare two documents

Perhaps you have an older version of your document, or a collaborator has sent you a document with
changes, but saved it as the same file name as the previous document. If tracked changes was not used,
how can you figure out what changes were made without reading the whole new document?
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Click “Tools” -> “Compare...” and select the two files you would like to compare. LYX can even create a
new document with the differences between the two tracked.

6.6 Use split view

You can use the “split-view” feature in LYX to view two parts of your document at the same time. Click
“View” -> “Split view into top/bottom” or “left/right”. Now you can see what you wrote in one part of
your document while you work on another part of your document. To leave the view click “View” ->
“Close current view”.

6.7 Insert extra space where you want it

If you want extra space between two sections of text, or maybe space between the end of your table and
the table’s note, you can add extra space by clicking “Insert”->”Formating” -> “Horizontal Space...” and
specifying your options. More info about spacing can be found here: http://wiki.lyx.org/FAQ/Spacing

7 Final Thoughts

This document has only focused on how to use LYX for producing documents, but the program can also be
used to produce presentations that one may traditionally have created using MS PowerPoint. The beamer
template that comes preloaded in LYX is a great start for interested users. In addition, for individuals who
have used MS Word to produce figures, such as path diagrams, a free program called Dia is a quite useful
alternative. A quick guide can by found in KU CRMDA KUant guides
(http://crmda.ku.edu/kuant-guides).

The largest drawback to LYX will most likely be collaborators who do not use it. There are a few
suggestions on how to take your LYX document and turn it into a Word doc, or vice versa (see
http://wiki.lyx.org/FAQ/ImportExport), but these methods may not be very reliable. If at all possible, I
recommend beginning your document in LYX rather than trying to move a Word doc over to LYX later.
Note, that because you can export the document as a PDF, other readers can still use software such as
Adobe X to edit/comment on your document. However, actual text editing would need to be down in LYX
or a text editor.

LYX can take some time for new users to learn, but this time can be a very good investment. Many
questions you have about LYX can quickly be resolved by an internet search. LYX has a built a great online
support community. Once you get the hang of LYX, you will likely find that you are able to write more
with less distractions, and produce beautifully formatted documents quicker. Moreover, LYX provides
greater flexibility and power to the user.
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